ShootProof affected by AWS outage

Incident Report for ShootProof

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:55 EDT

Update

We continue to actively monitor the situation and restore full service following the widespread AWS outage that has caused instability across the internet, affecting email delivery, gallery uploads, payment processing, and more.

Our team is monitoring the situation in real-time and working through the downstream effects as quickly as possible. We will provide an update as soon as the situation changes and service stabilizes. Thank you for your continued patience.
Posted Oct 20, 2025 - 14:02 EDT

Update

While many of the services provided by ShootProof have recovered, some are still in the process of recovering as it relates to the recently AWS Outage including ShootProof Pay and Stripe for International Studios.

While everything is coming back online, you may notice some latency, longer wait times to upload photos, send emails, or be prompted to sign up again for ShootProof Pay (Please DO NOT Sign up again).

We will keep you posted as we move forward.
Posted Oct 20, 2025 - 11:42 EDT

Monitoring

Some of the services provided by ShootProof were recently impacted by an AWS Outage. While everything is coming back online, you may notice some latency and longer wait times to upload photos, send emails, etc. Currently there's nothing you need to do on your end.

Our team is working closely to ensure these services are restored as soon as possible.
Posted Oct 20, 2025 - 08:36 EDT
This incident affected: Studio Panel, Email, and ShootProof Pay.